Download
(72 Kb)
Download
Updated: 02-20-13 09:55 AM
Pictures
File Info
Updated:02-20-13 09:55 AM
Created:01-02-13 09:32 AM
Downloads:2,302
Favorites:14
MD5:
Gadgets SCT
Version: 2.01r6
by: adelea [More]
Gadgets_SCT is a configurable scrolling combat text gadget.

Each gadget can be configured to show a subset or all of the events - Damage In/Out, Healing In/Out.

The number of events can be configured in each gadget, the colour of each event changed.

You can make them larger or smaller in each gadget, or change the fadeout time.

You can select a different font to display the text if you so wish.

Can select different layouts (order of icon / ability / value)
2.01r6:
- Added font selection
- ObelixPro from Valentin Antonov (http://www.dafont.com/obelixpro.font)
- Kronika from Apostrophic Labs (http://www.dafont.com/kronika.font)
- Can select different layouts (order of icon / ability / value)

2.01r5:
- Should now work if you dont also have Gadgets_Buffs installed

2.01r4:
- Check boxes for toggling ability names or target names were reversed.

2.01r3:
- Bug fix for outgoing damage + absorbs

2.01r2:
- Actually take notice of the show ability name + show target name options
- Added options to truncate player names (at the @ sign), and ability names (use first letter of each word in the name)
- Added options to hide overheals and absorbs
Archived Files (6)
File Name
Version
Size
Author
Date
2.01r5
8kB
adelea
01-07-13 03:49 PM
2.01r4
8kB
adelea
01-04-13 03:41 PM
2.01r3
8kB
adelea
01-03-13 02:14 PM
2.01r2
8kB
adelea
01-03-13 09:18 AM
2.01r1
7kB
adelea
01-02-13 09:32 AM
0B
adelea
12-31-69 06:00 PM


Post A Reply Comment Options
Old 02-25-13, 08:45 AM  
StuffedDuck

Forum posts: 0
File comments: 3
Uploads: 0
Re: Re: Re: Re: Getting following error message ...

Quote:
Originally Posted by adelea
Quote:
Originally Posted by StuffedDuck
Quote:
Originally Posted by adelea
Quote:
Originally Posted by StuffedDuck
Error: Gadgets_SCT/Gadget_SCT.lua:928: attempt to call field 'ListFonts' (a nil value)
In Gadgets_SCT / Gadget_SCT.lua
stack traceback:
Gadgets_SCT/Gadget_SCT.lua:928: in main chunk

I have updated all addons I got for rift recently (last 2 days) and have no real idea what to do.
Have you updated Gadgets itself (anything 0.3.96 or later) should work?
I have v0.3.98 installed
I cant see why you are getting this error then! =/

Line 928 of Gadgets_SCT is

local fontList = Library.Media.ListFonts()

And this is defined in

gadgets\wtLibMedia\wtMedia.lua: (though it was only added in 0.3.96)

If you open up the Gadgets_SCT\RiftAddon.toc file, and add an entry in the Dependencies section, so it looks like:

Code:
Dependencies    = {
Gadgets = {"required", "before"},
wtLibMedia = {"required", "before"},
}
Does that solve the issue? I wonder if it could be a code ordering problem, that I dont see due to something else.
It didn't solve the problem, but a fresh install of gadget and SCT did fix it

It was the first time I used the curse client to update my rift addons, might has messed something up.
StuffedDuck is offline Report comment to moderator  
Reply With Quote
Old 02-25-13, 03:34 AM  
adelea
Claw of Regulos
AddOn Author - Click to view AddOns

Forum posts: 22
File comments: 266
Uploads: 6
Re: Re: Re: Getting following error message ...

Quote:
Originally Posted by StuffedDuck
Quote:
Originally Posted by adelea
Quote:
Originally Posted by StuffedDuck
Error: Gadgets_SCT/Gadget_SCT.lua:928: attempt to call field 'ListFonts' (a nil value)
In Gadgets_SCT / Gadget_SCT.lua
stack traceback:
Gadgets_SCT/Gadget_SCT.lua:928: in main chunk

I have updated all addons I got for rift recently (last 2 days) and have no real idea what to do.
Have you updated Gadgets itself (anything 0.3.96 or later) should work?
I have v0.3.98 installed
I cant see why you are getting this error then! =/

Line 928 of Gadgets_SCT is

local fontList = Library.Media.ListFonts()

And this is defined in

gadgets\wtLibMedia\wtMedia.lua: (though it was only added in 0.3.96)

If you open up the Gadgets_SCT\RiftAddon.toc file, and add an entry in the Dependencies section, so it looks like:

Code:
Dependencies    = {
Gadgets = {"required", "before"},
wtLibMedia = {"required", "before"},
}
Does that solve the issue? I wonder if it could be a code ordering problem, that I dont see due to something else.
adelea is offline Report comment to moderator  
Reply With Quote
Old 02-25-13, 02:54 AM  
StuffedDuck

Forum posts: 0
File comments: 3
Uploads: 0
Re: Re: Getting following error message ...

Quote:
Originally Posted by adelea
Quote:
Originally Posted by StuffedDuck
Error: Gadgets_SCT/Gadget_SCT.lua:928: attempt to call field 'ListFonts' (a nil value)
In Gadgets_SCT / Gadget_SCT.lua
stack traceback:
Gadgets_SCT/Gadget_SCT.lua:928: in main chunk

I have updated all addons I got for rift recently (last 2 days) and have no real idea what to do.
Have you updated Gadgets itself (anything 0.3.96 or later) should work?
I have v0.3.98 installed
StuffedDuck is offline Report comment to moderator  
Reply With Quote
Old 02-24-13, 12:40 AM  
adelea
Claw of Regulos
AddOn Author - Click to view AddOns

Forum posts: 22
File comments: 266
Uploads: 6
Re: Getting following error message ...

Quote:
Originally Posted by StuffedDuck
Error: Gadgets_SCT/Gadget_SCT.lua:928: attempt to call field 'ListFonts' (a nil value)
In Gadgets_SCT / Gadget_SCT.lua
stack traceback:
Gadgets_SCT/Gadget_SCT.lua:928: in main chunk

I have updated all addons I got for rift recently (last 2 days) and have no real idea what to do.
Have you updated Gadgets itself (anything 0.3.96 or later) should work?
adelea is offline Report comment to moderator  
Reply With Quote
Old 02-23-13, 02:33 PM  
StuffedDuck

Forum posts: 0
File comments: 3
Uploads: 0
Getting following error message ...

Error: Gadgets_SCT/Gadget_SCT.lua:928: attempt to call field 'ListFonts' (a nil value)
In Gadgets_SCT / Gadget_SCT.lua
stack traceback:
Gadgets_SCT/Gadget_SCT.lua:928: in main chunk

I have updated all addons I got for rift recently (last 2 days) and have no real idea what to do.
StuffedDuck is offline Report comment to moderator  
Reply With Quote
Old 01-07-13, 02:06 PM  
adelea
Claw of Regulos
AddOn Author - Click to view AddOns

Forum posts: 22
File comments: 266
Uploads: 6
OK, I know why this is happening.

Gadgets_Buffs defines WT.CreateColourPicker

I will look into what I need to do in order to not depend on Gadgets_Buffs being present!
adelea is offline Report comment to moderator  
Reply With Quote
Old 01-07-13, 12:28 PM  
topiland

Forum posts: 0
File comments: 39
Uploads: 0
edit 1 eh posted bad line
i got it working after debugging
in gadgets....control/wtcolorpicker.lua line 266

local function CreateColourPicker(parent, r, g, b, a)

removed the local
function CreateColourPicker(parent, r, g, b, a)



in sct

c_DO = WT.CreateColourPicker(frmConfig, 0.8,0,0,1)
c_DI = WT.CreateColourPicker(frmConfig, 0.8,0.4,0.1,1)
c_HO = WT.CreateColourPicker(frmConfig, 0,0,0.8,1)
c_HI = WT.CreateColourPicker(frmConfig, 0,0.8,0,1)

changed to (removed WT.)

c_DO = CreateColourPicker(frmConfig, 0.8,0,0,1)
c_DI = CreateColourPicker(frmConfig, 0.8,0.4,0.1,1)
c_HO = CreateColourPicker(frmConfig, 0,0,0.8,1)
c_HI = CreateColourPicker(frmConfig, 0,0.8,0,1)
Last edited by topiland : 01-07-13 at 12:36 PM.
topiland is offline Report comment to moderator  
Reply With Quote
Old 01-07-13, 11:57 AM  
topiland

Forum posts: 0
File comments: 39
Uploads: 0
/script print(WT.Control.ColorPicker.Create) say info
topiland is offline Report comment to moderator  
Reply With Quote
Old 01-07-13, 11:56 AM  
Sebhael

Forum posts: 0
File comments: 1
Uploads: 0
I just downloaded this, figured I'd register to say that I'm having the same problem that topiland is having. I don't know too much about addons, but I ran (/script print(WT.CreateColourPicker)) like you had asked him - it prints out Nil for me as well.

Gadgets: 0.3.94
SCT: 2.01r4
Sebhael is offline Report comment to moderator  
Reply With Quote
Old 01-07-13, 11:40 AM  
topiland

Forum posts: 0
File comments: 39
Uploads: 0
not working and evrihign else in gadget work for me


even i removed the lines from ini with adeed by stats and outfitter
Last edited by topiland : 01-07-13 at 11:50 AM.
topiland is offline Report comment to moderator  
Reply With Quote
Old 01-07-13, 11:28 AM  
adelea
Claw of Regulos
AddOn Author - Click to view AddOns

Forum posts: 22
File comments: 266
Uploads: 6
Quote:
Originally Posted by topiland
it say nill

not in separate forlder alla doons used as embedded. i replaced embedded ones with 1.12

Restored original lib
Diasbled all addons
only gadgets and sct enabled.
Still same nill
For WT.CreateColourGadget (NB: capitalization matters!) to be nil, that suggests that gadgets itself isnt loaded - so I have no idea at all how anything you have is working!


Create a new folder in your Addons folder, and move everything into it. Then redownload jsut gadgets and gadgets_sct, and put them in your Addons folder (so there are just 3 things in it). Does it work then ?

I cant recreate the nil error - i've tried putting LSW in AddOns, I've updated the emebedded copy in gadgets to 1.12 - everything still works.
Last edited by adelea : 01-07-13 at 11:33 AM.
adelea is offline Report comment to moderator  
Reply With Quote
Old 01-07-13, 10:43 AM  
topiland

Forum posts: 0
File comments: 39
Uploads: 0
it say nill

not in separate forlder alla doons used as embedded. i replaced embedded ones with 1.12

Restored original lib
Diasbled all addons
only gadgets and sct enabled.
Still same nill
topiland is offline Report comment to moderator  
Reply With Quote
Old 01-07-13, 09:54 AM  
adelea
Claw of Regulos
AddOn Author - Click to view AddOns

Forum posts: 22
File comments: 266
Uploads: 6
Quote:
Originally Posted by topiland
up to date
using outfitter and stats plugin
libsimplewidget updated to 1.12
You have libsimplewidget installed seperately? In addition to the copy included with Gadgets?

I wonder if thats the problem - do you get the same error if you try and create another gadget that uses the color picker? The only one I have that does, is the Buff Bars / Buff Icons gadget.

EDIT: I installed LSW 1.12, and dont get any problems.

EDIT2:

What does /script print(WT.CreateColourPicker) do ?

Does it display: nil

Or: function: 0xxxxxxxxx ?
Last edited by adelea : 01-07-13 at 10:01 AM.
adelea is offline Report comment to moderator  
Reply With Quote
Old 01-07-13, 09:24 AM  
topiland

Forum posts: 0
File comments: 39
Uploads: 0
up to date
using outfitter and stats plugin
libsimplewidget updated to 1.12
Last edited by topiland : 01-07-13 at 09:26 AM.
topiland is offline Report comment to moderator  
Reply With Quote
Old 01-07-13, 02:01 AM  
adelea
Claw of Regulos
AddOn Author - Click to view AddOns

Forum posts: 22
File comments: 266
Uploads: 6
Quote:
Originally Posted by topiland
Error: Gadgets_SCT/Gadget_SCT.lua:202: attempt to call field 'CreateColourPicker' (a nil value)
In wtLibGadget / wtLibGadget.WTGadgetCreate_wrapper_SCT:LeftClick
stack traceback:
Gadgets_SCT/Gadget_SCT.lua:202: in function 'ConfigDialog'
wtLibGadget/dialogs/wtGadget_CreateDialog.lua:375: in function <wtLibGadget/dialogs/wtGadget_CreateDialog.lua:354>


Add gadget an just clik on sct


and not full config get loaded last show is out of combat capacity
That's using functionality from Gadgets itself - if this is failing, then I think there is something broken in your gadgets installation. What version of gadgets are you using ?
adelea is offline Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: